Switcher Studio Main Website Unavailable
Incident Report for Switcher Inc.
Resolved
This was an issue with CloudFlare and has been resolved.
Posted Jul 02, 2019 - 10:19 EDT
Investigating
Our hosting provider is experiencing difficulties. The Switcher Studio App, and Switcher Dashboard (https://dashboard.switcherstudio.com) are still available, it's only www.switcherstudio.com that is down.
Posted Jul 02, 2019 - 10:08 EDT
This incident affected: Web (Switcher Website).