Switcher Player, Multistreaming, and Video Library unavailable
Incident Report for Switcher Inc.
Resolved
All services have been restored to operational status. We will continue to monitor system stability closely.
Posted Nov 04, 2023 - 08:36 EDT
Update
Critical services have been restored, but are reported to be operating at degraded performance. We are continuing to actively monitor the situation.
Posted Nov 03, 2023 - 12:39 EDT
Update
We are still experiencing outages and are continuing to monitor this issue.
Posted Nov 03, 2023 - 09:04 EDT
Update
We are still experiencing outages and are continuing to monitor this issue.
Posted Nov 02, 2023 - 22:29 EDT
Update
We are still experiencing outages and are continuing to monitor this issue.
Posted Nov 02, 2023 - 18:36 EDT
Update
We are seeing gradual improvements and are monitoring the restoration of full functionality.
Posted Nov 02, 2023 - 16:29 EDT
Update
We are continuing to monitor this issue.
Posted Nov 02, 2023 - 14:33 EDT
Update
Power to our provider's data center has been partially restored. They are currently working to restore affected services and bring the data center back online.
Posted Nov 02, 2023 - 13:17 EDT
Update
We are continuing to monitor this issue.
Posted Nov 02, 2023 - 12:14 EDT
Update
Our underlying provider is still assessing a loss of power impacting data centres while simultaneously failing over services. They are working to resolve this problem.

We will keep providing regular updates until the issue is resolved.
Posted Nov 02, 2023 - 11:30 EDT
Update
One of our underlying providers is assessing a loss of power impacting data centres while simultaneously failing over services.

We will keep providing regular updates until the issue is resolved, thank you for your patience as we monitor this situation.
Posted Nov 02, 2023 - 10:21 EDT
Monitoring
We have identified a critical outage from one of our infrastructure providers which is impacting the Switcher Player and Multistreaming products. We are actively monitoring the situation.
Posted Nov 02, 2023 - 08:42 EDT
This incident affected: Apps (Switcher Studio App) and Services (Switcher Dashboard, Switcher Player).